VExtenso() e VExtenso Desktop

Escrever por extenso nas suas planilhas (e todos os outros programas)


Mil ou Um mil? Qual o certo?

07/Mar/2017 - 12:09, por VExtenso Admin

Segundo as normas de ortografia, você só precisa descrever a quantidade de milhares após a segunda unidade, por exemplo: "dois mil", "três mil", etc. Se for simplesmente "1.000", escreve-se MIL. A pessoa nasceu em mil novecentos e oitenta e um.

No entanto, é bastante comum e até aceitável que no Brasil escreva-se um mil e novecentos reais, principalmente quando nos referimos a quantias monetárias. Isso ocorre por diversos fatores, inclusive por uma questão cultural pois podia-se falsificar cheques, com alguns risquinhos fazer o 1 virar um 4 ou 7. Acrescentar a palavra Um na frente de Mil resolvia o problema.

Ainda assim, algun gênio descobriu que escrever um mil poderia ser falsificado com a caneta para outro valor, algo como Cem. Então, por fim, acrescentou-se o H e criou-se a palavra HUM, que ortograficamente está errada, mas serve ao propósito de evitar falsificações.

Você "erra" no Português e paga os mil, ou acerta no Português e fica devendo 99 mil. :-)

A função VExtenso escreve o Português correto: MIL REAIS. Mas se você necessitar acrescentar a palavrinha UM ou HUM na frente, segue abaixo uma fórmula especial para isso.

=SE(ÉERRO(LOCALIZAR("mil ";VExtenso(B9)));VExtenso(B9);SE(LOCALIZAR("mil ";VExtenso(B9))=1;"um "&VExtenso(B9);VExtenso(B9)))

* Substituia a célula B9 pela célula com o valor desejado.

Você também poderá adquirir o VExtenso Business, e você mesmo poderá alterar permanentemente para escrever do jeito que você precisa.

Fontes: http://brasilescola.uol.com.br/gramatica/um-mil-ou-mil.htm

Comentários:

Em 25/Jul/2018 - 14:44 Georgibson escreveu:
Muito bom essa sua fórmula para a inserção de "um" - não tenho a preocupação de colocar o H na frente. Vi tambem sua fórmula em excel para na hora da inserção de se colocar em maiúscula, a substituição do "De" par "de" e de "E" para "e", mas tem como nos ajudar e ver se consegue a formula para se ter ambos na mesma fórmula - a) colocação do "um" e b) no Pri.maiúscula do De e E minusculos.?
Nome:
E-mail:
Comentário:

Veja mais:

Microsoft Power Query - suplemento para Excel
Através do suplemento PowerQuery, da própria Microsoft, você pode incluir fontes de dados ...
Preenchimento de cheques com o VExtenso
Reunimos aqui neste artigo algumas das principais dicas para preenchimento de cheques automatizado utilizando o ...
Cheque: recuo inicial
Ao preencher cheques usando o VExtenso, pode ser necessário quebrar o texto em duas linhas, porém, devido ...
VExtenso em Kwanzas para Angola
Você pode utilizar o VExtenso em diversos idiomas e moedas. Consulte nos Parâmetros da ...
Ativar macros no OpenOffice
Atenção: estas informações se referem à versão Business do VExtenso! As ...
Dica - Auditoria de Fórmulas - Células Precedentes e Dependentes
Para facilitar o rastreio das fórmulas o Excel oferece o kit de ferramentas chamado "Auditoria de ...





Página Inicial
Ajuda do VExtenso
Comprar Licença Tradicional (Planilhas)
Comprar Licença VExtenso Desktop
2021 © vextenso.com.br

Desenvolvido no Brasil. Registrar é uma atitude LEGAL!
Contamos com seu apoio para trazer melhorias ao projeto.